[HOME]

pag1teto_help

 

 

# $ + 画像ファイルをのあるディレクトリを検索する

「検索」チェックボックスがチェックされている場合と、チェックされていない場合で、変換元ディレクトリを指定するリストボックスの内容が異なります。

「検索」がチェックしてある場合は、変換元ドライブを変更する度に、画像ファイル(*.bmp,*.dib,*.K gif,*.tif,*.tga,*.pcx,*.jpg)が存在するディレクトリだけがリストアップされます。

「検索」がチェックされていない場合は、普通のディレクトリリストボックスと同じ様に動作します。

このチェックボックスは、変換先のディレクトリには影響を与えません。

 

 

ディレクトリ単位で一括変換dir_ikka

 

# $ + 変換元(先)のドライブを選択する

変換元(先)のドライブを指定します。

変換元のドライブを変更したとき、「検索」チェックボックスがチェックされていると、ディレクトリを検索するために、多少余分に時間がかかります。

変換元と、変換先のパスが同じになっていると、一括変換することができません。

 

 

ディレクトリ単位で一括変換dir_ikka

 

# $ + 変換元(先)のディレクトリを指定する

変換元(先)のディレクトリを指定します。ダブルクリックだけではなく、クリックでも、ディレクトリの指定ができます。

変換元と、変換先のパスが同じになっていると、一括変換することができません。

 

 

ディレクトリ単位で一括変換dir_ikka

 

# $ + 変換元(先)の拡張子を指定する

変換元(先)の画像フォーマットを選択します。

{bml i_kinshi.bmp}jpegフォーマットは、本来24bitだけのものですから、8bitとjpegの組み合わせは画質を大幅に劣化させるだけなので、意味がありません。

 

 

# $ + 変換先の色の深さを指定する

ver0.47から、8bit,24bitのどちらへも階調変換を可能にしました。

ただし、24bitの時は、表示しません。

{bml i_kinshi.bmp}jpegと8bitの組み合わせは画質を大幅に劣化させるだけなので、意味がありません。

 

 

 

# $ + 新しいサブディレクトリを作成する

変換先のディレクトリのために、新しいサブディレクトリを指定したい場合があると思うので、サブディレクトリを作成する機能があります。

 

・新たに作成したいサブディレクトリの親ディレクトリに、変換先のディレクトリを移動します。

・新しいディレクトリの名前を、テキストボックスにキー入力します。

・作成ボタンをクリックします。

これで、新しいサブディレクトリが作成され、変換先ディレクトリが新しいディレクトリになります。

 

例えば、

現在の変換先のディレクトリが d:\pag1teto で、新しいサブディレクトリに、new_dir を指定して作成すると、d:\pag1teto\new_dirというディレクトリが作成され、そこが変換先ディレクトリになります。

 

 

ディレクトリ単位で一括変換dir_ikka

 

# $ + 不用なサブディレクトリを削除する

間違ったサブディレクトリを作成してしまう可能性があるので、サブディレクトリを削除する機能もあります。変換先のディレクトリに設定して、「削除」ボタンを押します。

ただし、削除可能なのは、空のディレクトリだけです。

 

 

ディレクトリ単位で一括変換dir_ikka

 

# $ + 一括変換を開始する

「一括変換」ボタンを押すと、指定された変換元にある画像ファイル(*.bmp,*.dib,*.tif,*.pcx,*.tga),の内、フルカラー画像ファイルをアルファベット順に変換して、変換先ディレクトリに書き込みます。

変換元のディレクトリと変換先のディレクトリが同じである場合は、開始出来ません。

 

中断機能は、1枚変換する度にチェックしています。

 

 

ディレクトリ単位で一括変換dir_ikka

 

# $ + 共通のパレット

メニューバー

「ファイル」

「ディレクトリ単位での一括変換」

「共通パレット...」

 

・目的

マルチメディアソフトや、HTMLなどで、複数の画像を1ページに納める場合や、小規模な動画などでパレット切り替えの時間が無い場合などで、256色環境で見る人を前提にしたソフトを作る場合に、共通パレットの256色パレット画像が必要になります。固定パレットでは、画質が悪くなりすぎます。

 

・動作

今回の機能は、VB側でだけ実現しています。この機能を使わなくても、複数画像を合成し、減色し、バラバラに切り分ければそれで良いわけで、同じことをやっています。

なお、そのために、フルカラーBMPに変換した時のサイズの合計で、16MB弱の画像しか扱えません。

 

・操作方法

独立パレットとほぼ同じなのですが、リサイズ機能とかを含めなかったので、別のダイアログにしました。

入力と出力のディレクトリと画像フォーマットを指定して、変換開始ボタンを押せば実行が始まります。

ver0.86現在中断ボタンがありません。済みません。

 

独立パレットで一括変換dokuritu_palette

 

 

 

# $ + 印刷

画面に表示しているサイズでモノクロ印刷します。プリンターの解像度に合せて拡大してからディザーを行います。拡大のアルゴリズムは、「オプション:拡大」で設定します。

なお、普通ディスプレーよりプリンターの解像度の方が大きいので、メモリーを大量に消費してスワップが発生しがちです。

 

僕はモノクロプリンターしか持っていないので、 モノクロ1bitで送らないと奇麗にプリントできませんでした。フルカラープリンターを持っている人のために、減色genshoku_imiせずにそのままプリントすることもできるようにしています。

 

しかし、フルカラーではないカラープリンターを持っている人で、デジタル8色にしてから、そのまま印刷すると、解像度が低いものの一応印刷できるプリンターがあったりすれば、Emailしてください。デジタル8色化してから印刷する機能も付けます。

 

{bml i_seigen.bmp}プリンターDCを調べればフルカラーを受け取れるかどうかわかるのでしょうが、まだやっていません。

 

 

# $ + 過去に変換したファイルのリスト

過去に表示したファイルのリストを表示しています。そのどれかをクリックすることでも、その画像ファイルを開くことができます。

 

# $ + ツール

画像に対するマウス操作の意味を変更します。起動直後は、「画像の移動」になっています。

 

画像の移動image_move

矩形の切り張りimage_copy

矩形のズームimage_zoom

 

レタッチの範囲を選択します。

矩形内のレタッチkukei_nai

矩形外のレタッチkukei_gai

 

{bml i_kinshi.bmp}ver0.46までは、マウスによって画像に対して可能な操作は、画像の移動だけでした。ですから、ツールメニューはありませんでした。

 

 

# $ + 移動

大きな画像を表示した場合に、マウスによる操作で画像をドラッグすることで、隠れている部分を見ることができます。その時、マウスカーソルは、上向き矢印(↑)になっています。

 

{bml i_hint.bmp}この他に、大きな画像を見る方法としては、「表示」「内接ズーム」を選択して、縮小して全体を表示する方法があります。

 

 

# $ + 矩形の切り張り

「ツール」「矩形の切り張り」を選択することで、マウス操作で、画像の一部を切り取って、表示している画像に張り付けることができます。

 

1.選択範囲を指定するcut_tejun_1

2.選択範囲を移動するcut_tejun_2

3.選択範囲を張り付けるcut_tejun_3

4.選択範囲を取り消すcut_tejun_4

手順は、オプションの設定で、多少、変化します。

 

選択範囲は、「編集」「クリップボードへの張り付けcut_to_clip」で、クリップボードとの間でもやりとりが可能です。

 

{bml i_hint.bmp}画像←→矩形の選択範囲と、矩形の選択範囲←→クリップボードという2つの関係があって、前者ではパレットの変更はともないませんが、後者では、減色genshoku_imiが起こります。

 

 

必要な部分を切り取って、ファイルにするkiritori

 

 

# $ + 矩形の切り貼り 1.選択範囲を指定する

選択範囲の矩形の1つの頂点で、マウスの左ボタンを押し、押したまま、その対角に移動して左ボタンを離します。

これで、選択範囲が決定します。選択された範囲には、斜線のハッチングがかかります。

 

この状態で、レタッチ機能を使うと、矩形の範囲内についてだけレタッチを行う事ができます。

 

オプション 切り取り跡を白くするoption_cut_white

 

 

# $ + 矩形の切り貼り 2.選択範囲を移動する

マウスを選択された矩形の上に移動し、左ボタンを押し、押したまま移動して、ボタンを離すことで、選択範囲が移動します。

 

オプション 軌跡にも複製するoption_copy_locus

 

 

# $ + 矩形の切り貼り 3.選択範囲を張り付ける

マウスで、画像の選択範囲以外の部分をクリックすることで、新しい選択範囲が選択し始められると同時に、選択された矩形が、張り付けられます。

 

オプション 右クリックで張り付けるoption_right_click

オプション ボタンを離すと、張り付けるoption_mouse_up

 

クリップボードからの画像を張り付ける場合には、2つの画像のパレットが異なるので、両方の画像をいったんフルカラーにしてから張り付けます。張り付け後の画像はフルカラーです。その後で、必要であれば、減色genshoku_imiしてください。

 

 

# $ + 矩形の切り貼り 4.選択範囲を取り消す

・マウスでフォームの画像以外の部分をクリックすることで、選択範囲が消えます。

・あるいは、メニューバーの「ツール」の下位のメニューを選択することでも、選択範囲が消えます。

・また、新しい画像を読み込むことでも選択範囲が消えます。

 

 

# $ + 必要な部分を切り取って、ファイルにする

例えば、256*256のサイズの画像を切り出す時には、まず、切り取る画像より大きな範囲切り取って、クリップボードに移動します。

次に、メニューバーの「ファイル」「白紙を用意するwhite_paper」で、256*256の白紙を作り、そこにクリップボードから選択範囲に移動して、位置を決めてペーストします。

最後にファイルにセーブします。

 

 

 

# $ + 矩形のズーム

「矩形のズーム」ツールを選択することで、マウス操作で、画像の一部を指定して、その範囲を、フォーム全体に内接するようにズームすることができます。

 

1.選択範囲を指定する

選択範囲の矩形の1つの頂点で、マウスの左ボタンを押し、押したまま、その対角に移動して左ボタンを離します。

これで、選択範囲が決定します。選択された範囲は、フォーム全体に内接するようにズームします。

 

2.ズームされた選択範囲を移動する

マウスを選択された矩形の上に移動し、左ボタンを押し、移動して離すことで、選択範囲が移動します。

 

3.選択範囲を取り消す

・マウスでフォームの画像以外の部分をクリックすることで、選択範囲が消えます。

・あるいは、メニューバーの「ツール」の下位のメニューを選択することでも、選択範囲が消えます。

・また、新しい画像を読み込むことでも選択範囲が消えます。

 

{bml i_seigen.bmp}ただし、8倍を越える倍率にはズームできません。

 

{bml i_hint.bmp}これは、画像全体のズームではありません。選択した矩形範囲だけを拡大します。画像全体を任意の倍率でズームて、ずらして表示したい場合には、「ウィンドウ」「カーソル位置cursor」の中にあるズーム倍率のスクロールバーを操作してください。

 

 

 

# $ + 矩形内のレタッチ

選択範囲内のレタッチを行ないます。

 

 

# $ + 矩形外のレタッチ

選択範囲外のレタッチを行ないます。

 

{bml i_hint.bmp}例えば、関係無い部分を平滑化するという様なことが考えられます。

 

# $ + 切り貼り

選択矩形をクリップボードとの間でやりとりしたりする機能です。

 

クリップボードへ移動cut_to_clip

クリップボードへコピーcopy_to_clip

クリップボードから貼り付けcopy_from_clip

 

全選択zen_sentaku

 

Clipboardから画像への貼り付けclip_to_image

トリミングtrimming

 

 

 

# $ + 選択範囲をクリップボードへ移動

「ツール」「切り取り」で、切り取った斜線のかかった矩形を、クリップボードに移動します。切り取った斜線のかかった矩形はなくなります。

選択範囲が選択されていなければ、この機能は、灰色になっていて使えません。

クリップボードには、DIBとパレットが入ります。さらに、8bit環境で24bit画像を扱っている場合には、Bitmapに8bit画像が入ります。

 

{bml i_hint.bmp}8bitディスプレーの時には、DIB自体にパレットの情報が入っているわけですが、フルカラーの画像であっても、パレットをクリップボードにコピーします。これは、Windowsについてくるクリップボードの内容を表示するアプリケーションであるclipbrd.exeが、フルカラーDIBを8bit環境で表示するときに、もしもクリップボードにパレットがなければ、勝手なパレットを使って表示してしまうためです。

 

{bml i_hint.bmp}クリップボードについてclipboard

 

 

# $ + クリップボードについて

クリップボードに関係して、Windowsに標準でついてくるペイントブラシですが、あのソフトを8bit環境で使って、編集メニューの切り取りやコピーを行うと、DIB(Bitmap)だけが渡されて、パレットがクリップボードにコピーされません。

 

さらに、クリップボードにDIBがあれば問題ありませんが、[graph]+[copy]とか、[alt]+[print screen]でコピーした場合の様に、ディバイス依存ビットマップ(DDB(いわゆるBitmapです))とパレットだけをクリップボードに受け渡すソフトの場合には、ペイントブラシがDDBだけしか受け取らずにパレットは放置するので困ったことになります。たまたまハード上にパレットの情報が保持されているので、表示や編集をしている時には、問題が無いように見えていますが、それをセーブしてみると、空っぽのパレットがセーブされているので、真っ黒だったということになります。

 

 

 

# $ + 選択範囲をクリップボードへコピー

「ツール」「切り取り」で、切り取った斜線のかかった矩形を、クリップボードに移動します。コピーなので、切り取った斜線のかかった矩形はそのまま残ります。

選択範囲が選択されていなければ、この機能は、灰色になっていて使えません。

クリップボードには、DIBとパレットが入ります。8bitディスプレーの時には、Bitmapに8bit画像が入っています。また、フルカラーの画像であっても、パレットの情報が入っています。

 

 

# $ + 選択範囲へクリップボードから貼り付け

クリップボードから、選択領域に貼り付けます。

 

異なるパレット間の貼り付けでは、減色が起こります。

クリップボードのデータがフルカラーデータであった場合には、8bitディスプレーで使っている時には、この段階で減色genshoku_imiが起こります。

クリップボードにDIBまたは、Bitmapがなければ、このメニューは選択できません。

 

8bitディスプレーでは、選択領域のパレットと、表示されている画像のパレットが異なっているのが普通です。

 

{bml i_hint.bmp}もしも、8bit環境で、何度もペーストする場合は、いったん、選択領域を切り取りなおせば、同じパレットになるので、減色genshoku_imiが不用になり速く操作できます。

 

{bml i_seigen.bmp}ver0.47現在では複数のビットマップを共通パレットで表示する仕様にはなっていません。ですから、異なるパレットの2枚の画像が表示されている状態では、下に表示されている画像は、ひどい画質になります。8bitディスプレーで途中の過程で、表示が汚くなる場合でも、選択領域の画像へのペーストは正しく、行われています。

 

画像に選択範囲をペーストした段階でも、減色genshoku_imiが起こります。

 

貼り付けが終わった段階でも、選択範囲が残っていれば、そのパレットは、最初の時のままなので、ペーストされた画像と、異なるパレットになっています。ですから8bitでの表示は汚いままです。ツール「移動」を選択するとか、フォームを広げて、フォームの画像でない部分をクリックするかで、選択領域が消えた段階で、ペーストされた画像が、正しいパレットで表示されます。

 

「オプション」「全般のオプション」「用紙を拡大して貼り付け」zoom_paste

 

 

 

# $ + 選択範囲をファイルへ移動

 

# $ + 選択範囲をファイルへコピー

 

# $ + 選択範囲へファイルからコピー

 

# $ + 全選択

「ツール」「矩形の切り貼りimage_copy」にしてマウスで左上の端から右下の端まで選択するのと同じです。

マウスで丁度の大きさを選択するのは難しいので、全体を選択する場合には、こっちの方が簡単便利です。

 

{bml i_seigen.bmp}他のソフトでは、最初から全選択の状態になっているようなので、将来的にそう変更するかも知れません。とりあえずver0.83現在でも、明示的に全選択をする必要があります。

 

 

# $ + Clipboardから画像への貼り付け

普通の経路は、以下のようになっています。

画像 <-> 選択矩形 <-> クリップボード

それに対して、この機能では、クリップボードにある画像を直接編集対象にします。

 

 

# $ + トリミング

メニューバー

「切り貼り」

「トリミング」

 

選択矩形の外側を捨てます。

 

 

# $ + 編集

元に戻すundo

 

左上を中心にスクロールscroll_to_center

スクロール...scroll

 

用紙だけの拡大zoom_paper

 

リサイズresize

ミラーmirror

回転rotate

モノクロ化monocro

 

24bit化bit_24

8bit化bit_8

4bit化bit_4

1bit化bit_1

 

色数を数えるcolor_count

 

 

ファイルへ移動cut_to_file

ファイルへコピーcopy_to_file

ファイルからコピーcopy_from_file

 

# $ + 元に戻す

メニューバーの「編集」や、「レタッチ」の下位にある機能を使った時には、1度だけ取り消すことができます。

 

{bml i_option.bmp}元に戻せなくするcan_not_undoことでK メモリーを節約できます。

 

 

# $ + 左上を中心にスクロール

繰り返しパタンの壁紙を作るときに、ずらした画像をみたい場合が多いと思います。この機能が無くても、切り貼り2回分の手間ですが、追加しました。

 

{bml i_hint.bmp}任意の場所にずらす場合には、1つ下の段の「スクロール...」を選択してください。

 

 

# $ + スクロール

繰り返しパタンの壁紙を作るときに、ずらした画像をみたい場合が多いと思います。この機能が無くても、切り貼り2回分の手間ですが、追加しました。

 

{bml i_hint.bmp}中心にずらせば良い場合は、1つ上の段の「左上を中心にスクロール」を選択してください。

 

 

 

# $ + 用紙だけを拡大

画像自体は拡大することなく、白い用紙を、右下に向けて拡大します。

 

{bml i_hint.bmp}pag1tetoでは必要ないと思いますが、重要な部分を完全に減色したい場合、その部分を切り出して、拡大した部分に貼り付けて、減色すれば、その部分により多くのパレットが使われて高画質になります。

 

 

 

# $ + リサイズ

画像を拡大縮小します。セーブするとファイルサイズが変化します。

サイズの指定方法は、

倍率で指定

サイズで指定

表示通りのサイズにする

の3通りがあります。

 

{bml i_rekisi.bmp}ver0.83から縦横比を変更すことが可能になりました。その場合は、サイズ指定で、アスペクト比を変更するを選択してください。

 

{bml i_option.bmp}「オプション」「拡大kakudai_option」で、補間のアルゴリズムとアンチエイリアシングの有無を選択することができます。

 

{bml i_hint.bmp}単に大きく表示したいだけなら「オプション」「オプション:拡大kakudai_option」「ズームのモード」を変えることでも可能です。

 

{bml i_kinshi.bmp}16MBを越えたり、残りメモリーを越える大きなサイズにしようとするとK メモリー不足のエラーが出てしまう可能性があります。

 

 

 

# $ + ミラー

左右反転、上下反転ができます。

 

 

# $ + 回転

90度単位の回転と、1度単位の回転ができます。

 

{bml i_option.bmp}1度単位の回転を行う場合には、余白が出来るので、その部分の色も指定してください。

 

 

# $ + モノクロ化

モノクロ8bitに変換します。

 

{bml i_seigen.bmp}これは、ImageKnifeの機能をそのまま使っているのですが、Windowsの20色(正確に言えば、20色の内の4色はモノクロなので、その内の16色)のパレットが含まれていません。そのために、普通のビューアーでは、最も明るい方の16階調程(8bit画像をモノクロ化した場合には、パレットの最後の方の16色程ですが明るいかどうかは元のパレットに依存します。)がはみ出してしまいます。

これを回避するためには、減色しなおすre_genshoku必要があります。

 

# $ + 減色genshoku_imiしなおす

モノクロ8bit化を行った時には、Windows用の20色が含まれていません。また、Mac起源の8bit画像にもWindows用の20色のパレットが含まれていません。これらを、普通のWindows用のソフトで表示すると、パレットの最後の20色がはみ出してしまい、別の似た色で代用されてしまいます。

 

これを回避するためには、モノクロ化したものを

ネガ化

24bit化

ネガ化

8bit化

という操作をする必要があります。

 

この操作は、Windows用の20色のパレットが含まれていない8bit画像ファイルに、20色を含ませる時の操作でもあります。単に、

24bit化

8bit化

とするだけでは、減色genshoku_imiは行わず、表示を切り替えるだけです。

 

 

 

# $ + 24bit化

8bitのファイルを24bitに変換します。

 

 

# $ + 8bit化

24bitのファイルを8bitに変換します。

 

 

# $ + 4bit化

K 16色に減色genshoku_imiします。

 

 

減色genshoku_imiのオプションは、「オプション」「パレットのオプションgenshoku_option」と、「擬似階調表示のオプション」で設定します。

 

16色ディスプレーではパレットが使えない事が多いので、あまり使わないかも知れません。

 

 

 

# $ + 1bit化

2色に減色genshoku_imiします。

 

{bml i_rekisi.bmp}ver0.58から追加しました。

 

 

 

# $ + 色数を数える

画像に使われている色の数を数えます。ただし、65536色以上は数えることができません。

 

{bml i_rekisi.bmp}ver0.83から追加しました。

 

{bml i_hint.bmp}画質評価で固定パレットn色相当という表現をしていますが、当然ながら、これとは別です。例えば、JPEG画像の画質を見るのに、この色数を調べても、あまり直接的な評価になるとは思えません。

 

また、減色時のヒストグラムとは違って、精度を落とさずrgb各8bitでの1600万色中の色数です。

 

 

# $ + レタッチ

色の変換

色の射影projection

輝度・コントラストbright

γ補正gamma

ネガnega

 

フィルター処理

ぼかすblur

ソフト化soften

シャープ化sharp

エッジ抽出edge

3x3または、5x5のフィルターcustom_filter

 

 

 

# $ + 色の射影

色空間内で使える色をデジタル8色を含む直線や平面上の色の組み合わせによる表現に限定する機能です。様々なバリエーションが考えられますが、とりあえず現在は3種類の機能を実現しました。{表面と中心、サーモグラフィー風、色度だけ}の3種類です。

 

{bml i_seigen.bmp}24bit画像に対してだけ有効です。

 

●表面と中心

この機能は、本来は、ディザーパタンにクレヨン風のタッチの物を使うことで、写真を手書き風の絵に変換しようと思って作った機能です。ただし、なかなか思った様な効果は得られませんでした。かなり大きな画像に対して、細かいディザパタンを使わないと、いかにも機械的に作ったことが判ってしまいます。TVCMによれば、スーファミ用のソフトで、そういう手書き風のタッチを生かしたソフトがある様で、これも、すでに他のソフトにある機能なのかも知れません。

画用紙の上に、クレヨン風のテクスチャーで描くという場合に対応させて説明すると、中心の色は、画用紙の色に相当します。色立体の表面の色は、クレヨンの色に相当します。それらの面積比は、クレヨンの疎密に相当します。

例えば、中心の色を灰色にして、ディザーパタンを無しにすると、HSIの円筒モデルで考えた場合の彩度最大の画像になります。ただし、中心の色に近い色程、明度も大きく変化してしまいます。

 

アルゴリズムの説明

色立体中のすべての色は、色立体の表面の色と、中心になる任意の色の重心結合で表現できます。別の言い方をすれば、すべての色を、与えられた中心の色から色立体の表面に射影することができます。つまり、画像の色と、オプションとして指定した中心の色から、色立体の表面の色と、両者の重みの比を求めることができます。その結果、ディザーパタンを使って中心の色と、色立体の表面の色を混ぜあわせることで元画像を近似的に表現できます。

 

●サーモグラフィー風

この機能では、フルカラー画像を、HSIの双円錐モデルで考えた場合の彩度100%の色と、白から黒までの線上の灰色の重心結合に変換します。色相は変化させません。

ディザーパタンの機能は、上の場合と同じです。この場合は、意味がより簡単で、明度、色相、彩度が、2つの画像とディザーによる2つの画像の比率で表現されるということになります。明度は、モノクロ画像で表現され、色相は、彩度100%のサーモグラフィー風の画像で表現され、彩度は、それらの面積比で表現されているわけです。

ディザーパタンを無しにした場合には、彩度100%の画像に変換されるので、サーモグラフィー風の画像になり、とても派手になります。使いみちがあるかどうかは知りません。

しかし、こんな役に立ちそうもない機能も、オリジナルというわけではなく、良く調べていないので勘違いかも知れませんが、すでにCoralDrawの付録ソフトとかに同じ様な機能が存在する様です。

 

ここでの明度は、NTSCにおけるY信号とは違って、(R+G+B)/3です。

 

なお、本来のサーモグラフィーの画像は、モノクロ256階調の画像を差をはっきりと目立たせるために、色の差として表現しているシュードカラーです。それはそれで別に実現しようと思っています。この機能は、使う色が同じというだけで、元画像との関係は違います。

 

●色度だけ

マンセルの色立体の中央部分を水平に切った断面というか、双6角錐モデルでの、角錐の底面というか、明度の成分を取り除いた残りというか、そういう画像に変換します。さらに例えて言えば、黄色い画用紙の上に、赤と青の絵の具だけで絵を書いた様な色に変換します。色を変換するだけの機能です。ここにはディザーパタンは関係ありません。

 

 

# $ + ぼかす

ピンボケ画像を作るImageKnifeの関数です。

周囲の9dotの平均が新しいdotの明るさになります。

行列で言えば、

1/9 1/9 1/9

1/9 1/9 1/9

1/9 1/9 1/9

というものになります。

 

{bml i_seigen.bmp}24bit画像に対してだけ有効です。

 

 

 

# $ + ソフト化

平滑化します。度合を1から10の間の整数で指定します。

10の時には、

1/16 2/16 1/16

2/16 4/16 2/16

1/16 2/16 1/16

1の時には、

1/32 2/32 1/32

2/32 20/32 2/32

1/32 2/32 1/32

と10の時の半分の効果になる様です。

多分、行列を

a b a

b c b

a b a

パラメーターをpとすると、

a=(1+(p-1)/9*1)/32

b=2*a

c=1-12*a

となっている様です。でも、8bit精度で計算して切り捨てが行われているので、正確ではありません。

 

24bit画像に対してだけ有効です。

 

 

# $ + シャープ化

ソフト化の反対です。

24bit画像に対してだけ有効です。

 

 

 

# $ + 3x3,5x5のフィルター

任意のフィルターを設定できます。

例えば、上下に揺れている感じにするために

0 0 1 0 0

0 0 1 0 0

0 0 1 0 0

0 0 1 0 0

0 0 1 0 0

こんな風なパラメーターにするとかです。

 

作ったフィルター行列に名前を付けて記憶する機能はver0.86現在まだ出来ていません。

 

 

 

# $ + 輝度・コントラスト

輝度とコントラストは一度に変更できます。

 

 

# $ + γ補正

γ補正ですが、定数が1の時に、そのままになるのではなく、1から10のうちの、5の時にそのままになります。ImageKnifeの仕様がどうなっているのか、ver0.43現在まだ調べていません。

 

 

# $ + ネガ

色を反転させます。

 

 

# $ + エッジ抽出

エッジ部分を抽出します。

 

# $ K + オプション

さまざまなオプションが一箇所にまとまっています。

 

全般...zenpan_option

減色...genshoku_option

拡大...kakudai_option

 

{bml i_rekisi.bmp}DOS版のpag1tetoでは、(起動時のオプション)コマンドラインからオプションを指定していましたが、Windows版のpag1tetoでは、コマンドラインではオプションは受け取りません。「オプション」の下位のダイアログで指定して下さい。なお、ver0.45以降、ファイルマネージャーのダブルクリックで起動できるように、コマンドラインから、画像ファイルだけは指定できるようにしました。

 

ver0.52からは、表示とその他のオプションを1つのフォームにまとめました。上位レベルに戻らずに他のオプション設定に移動できます。

 

ver0.58からは、拡大のオプションを別のページに分けました。

 

 

# $ + オプション:全般

表示

スタティックカラーを2色にするstatic_color_2

その他

コモンダイアログを使うcommon_dialog

ヘッダーファイルサイズチェックheader_file_size_check

DLLへの画像をファイルで受け渡すdll_by_file

減色をするだけで表示しないnot_disp

変換終了時のビープ音を消すend_beep

変換終了時、進捗状況のフォームを消さないcurrent_always

K JPEGセーブ時の圧縮品質.jpeg_option

フォームの色form_color

切り貼り

切り取り跡を白くするoption_cut_white

軌跡にも複製するoption_copy_locus

右クリックで複製するoption_right_click

ボタンを離すと、張り付けるoption_mouse_up

張り付け後、矩形を消すpaste_and_off

ショートカットキーをCtrl+x,c,vにするshort_cut_xcv

 

# $ + スタティックカラーを2色にする

スタティックカラー2色の設定にすると、白と黒と、最適化パレット254色からなるパレットの画像を正しく表示できます。同じ画像をスタティックカラー20色の設定で使うと、はみ出した18色分の色は、近い色で置き換えられます。

もしも、K 16色でなおかつパレットをサポートしているディスプレードライバーがあれば、白と黒と最適化パレット14色で表示できるわけですが、16色ではパレットをサポートしないディスプレードライバーが普通の様です。

スタティックカラー2色の設定で使うと、起動時に、背景になっている他のアプリケーションを白と黒で表示しなおすので、時間がかかります。

 

 

# $ K + コモンダイアログを使う

pag1teto ver0.42までは、読み込むファイルを選択するのにコモンダイアログを使っていました。しかし、コモンダイアログが出てくるまでの時間が長いので、いろいろな画像を次々と見るという様な使い方をする場合に、不便でした。そこで、ver0.43からは、専用のファイラーが常に表示されている状態を標準にしました。コモンダイアログは、オプションにして、互換性を保つために存在しています。

ただし、画像を保存する場合には、このオプションに関りなくコモンダイアログを使います。

 

# $ K + ヘッダーファイルサイズチェック

pag1teto ver0.23までは、ビットマップファイルのヘッダー部分に記録されているファイルサイズと、実際のファイルサイズが一致しているかどうかをチェックして、違っていたら、エラーメッセージを出すようになっていました。

 

しかし、一部のソフトでは、本来はファイルサイズが入っている部分に、0が入っていたり、ファイルサイズの1/2の値が入っていたりする場合があって、このために、他のソフトでは表示できるのに、pag1tetoでは表示できないことがありました。

 

ということで、標準ではファイルサイズのチェックを行わずに、オプションでチェックすることにしました。

 

# $ K + DLLへの画像をファイルで受け渡す

 

{bml i_kinshi.bmp}pag1teto ver0.42までは、減色genshoku_imiを行うpag1win.dllやpag1wini.dllに対して、フルカラー画像をビットマップファイルで渡し、減色genshoku_imiされた画像をまたビットマップファイルで受け取る様になっていました。そのために、時間がかかっていました。

そこで、ver0.43では、標準ではファイルではなくK メモリで受け渡すようにしました。

 

メモリー渡しにした場合by_ram

ファイル渡しにした場合by_file

 

# $ + DLLへ画像をメモリーで受け渡す場合

利点は、速度が速くなったことです。それにともなって、ImageKnifeの機能を使った後で減色genshoku_imiする時のオーバーヘッドがなくなりました。そこで、レタッチ機能を付加しました。なお、レタッチ機能を使う場合には、オプションの設定に関らず、メモリー渡しで減色genshoku_imiしています。

ただし、K メモリ渡しにも欠点があります。それは、減色genshoku_imiできる画像のサイズがメモリーのサイズによって制限されるということです。例えば、4MBのフルカラーイメージを1.3MBの減色genshoku_imiイメージに変換する場合には、それだけで、5.3MBが必要になります。プログラムを起動した段階で、実メモリーがそれ以下しか残っていない場合には、スワップが生じて、本来のメリットである速度が達成できなくなります。

 

 

# $ + DLLへ画像をファイルで受け渡す場合

速度が遅くなるのが欠点です。しかし、減色genshoku_imiだけならば、あまりK メモリーを消費せずに、大きなファイルが変換できます。ただし、ファイル渡しで変換できるのは、ImageKnifeを使わずに済むビットマップフォーマットの時だけです。他のフォーマットの時には、必要になるメモリーは、メモリー渡しの場合と比べてそんなに大きな差はありません。減色genshoku_imi画像1枚分くらいは少ないメモリーで済むくらいです。

 

実メモリーが少ないにも関らず、大きなファイルを変換する場合には、DLLへファイルで渡すオプションを選択して、さらに減色genshoku_imi画像を表示しないオプションを選択すれば、さらに少ないメモリーで変換できます。

 

さらに言えば、変換画像の画質に制限がつきますが、DOS版を使って変換すれば、640KBのメモリで、32Kdot*32Kdotのファイルが変換できるはずです。ただし、ver0.42以前のソフトには、第一主成分による分割の場合で、13.8MB以上のファイル、RGBのいずれかによる空間分割の場合で、24MB以上のファイルの場合で、正しく減色genshoku_imiできない場合がありました。実際にこれだけの大きさのファイルを変換してみたわけではありませんが、プログラム中の変数の精度の都合上そうなっていました。

 

# $ K + 減色genshoku_imiをするだけで、表示しない

一括変換の時には、別に毎回表示しなくても良いかも知れないと思ってこういうオプションを追加しました。K メモリーを節約できる以外には、あまりメリットはないと思います。

 

# $ K + 変換終了時のビープ音を消す

このオプションも、説明を付け加えるまでもないものです。

 

CD-ROMを作るために数百枚のファイルを画質重視モードで変換しているユーザーからの要望で眠っている間に変換が行えるようにということで、ver0.42から付けました。そういえば、DOS/Vマシンのビープ音にはボリュームが付いていないという記事を読んだことがあります。僕の環境では、ビープではなく、ジャジャーンとwavファイルの音が鳴っています。

 

 

# $ + 変換終了時に、進捗状況のフォームを消さない

画像のサイズや階調の情報を見たい人のために、減色が終わってもすぐにはフォームを消さないオプションを追加しました。

 

{bml i_hint.bmp}手動で消したい場合には、「ウィンドウ」「進捗状況shinchoku」の所をクリックしてください。

 

 

# $ + 元に戻せなくする

「編集」「元に戻すundo」の実現のためには、扱う画像分のK メモリー(8bitモードでは、その1.333倍)が必要になります。これを禁止すれば、その分メモリーが節約できます。

 

大きな画像を扱う場合で、スワップが起こって遅くて困る場合に使ってください。

 

# $ K + JPEGセーブ時の圧縮品質

このメニューをクリックすると、ダイアログが出てきます。5から100の間でJPEGの圧縮品質を設定できます。

 

 

# $ + フォームの色を変更する

「フォームの色」コマンドボタンをクリックすると、フォームの背景色を変更するためのフォームにジャンプします。

 

# $ + 切り取り跡を白くする

このオプションがチェックしてあると、元の画像の選択範囲部分が白くなります。

 

 

# $ + オプション 軌跡にも複製する

このオプションがチェックしてあると、選択範囲を移動中に、つぎつぎ張り付けを行います。あまり実用的ではありませんが、ver0.47現在、ペン機能が無いので、無いよりましかも知れません。

 

 

# $ + 右クリックで複製する

このオプションがチェックしてあると、右クリックによっても、張り付けできます。

デフォルトでは、このオプションはチェックしてあります。

 

 

# $ + ボタンを離すと張り付ける

このオプションがチェックしてあると、移動が終わったらすぐその位置に張り付けを行います。左ボタンを押した状態で、位置の微調整を一発で行う必要があるので、やりなおしが効かないとかえって不便かもしれないのですが、この操作方法の方が簡潔で好きな人もいるかも知れません。

 

 

# $ + 張り付けた後、矩形を消す

8bitモードで使っていると、張り付けた後、矩形が残っていると、パレットが異なるために、背景の画像が奇麗に表示されません。矩形を消すには、「ツール」の選択を行うなどの処理でも良いわけですが、このチェックボックスがチェックしてあれば、その手間を省略できます。

 

 

# $ + ショートカットキーをCtrl+X,C,Vに変更する

両方のショートカットが使えれば良いのですが、VBで作っているので、ちょっとその方法が思い付きません。、どちらか一方、自分の慣れたキーを選んでください。

カット Ctrl+X Ctrl+Del
コピー Ctrl+C Ctrl+Ins
ペースト Ctrl+V Shift+Ins

 

 

# $ + 用紙を拡大して貼り付け

 

{bml i_rekisi.bmp}表示している画像からはみ出した位置で貼り付けを確定すると、ver0.79までは、切り捨てていました。ver0.80からは、このオプションがチェックしてあれば、用紙を拡大して貼り付けるようにしました。

 

 

 

pag1teto_help

Google
Web www.PAG1U.net

seo
Tibet Support Network Japan(TSNJ)チベット・サポート・ネットワーク・ジャパン チベットの今日は、明日の台湾、あさっての日本ということで心配なので、リンクだけ貼っておきます。

[HOME]  (C) MATSUOKA , Hajime